OfficeMachines.net - Powered by Ruffles
Price Beat Guarantee
International: +44 1293 775 248
FREE GB Mainland Delivery on orders over 100 + vat
Home
Shopping
Basket
Contact Us

Philips LFH7277 SpeechExec Pro Transcription Kit and Software (LFH7277/00)

Print E-mail
RRP: £229.00 - You Save: £82.05 (36%)
£146.95 + vat   (£176.34 inc vat)
2 or more for £144.95 each
Code: LFH7277

Jump to: Full Product Information

  • SpeechExec PRO transcribe software
  • LFH2330 USB foot control
  • LFH334 earphones
  • Includes licence
  • Weight: 0.61kg
  • Dimensions (WxDxH): 160x18x150mm
Quantity: 
Expected Delivery Time: 1-2 days

Need Help?

Email or Call The Experts

0845 5555 007

Price Beat Guarantee

Supplies, Accessories & Related Products

Philips Headphones for Desktop Dictation Equipment
£52.76 + vat
2 or more for £50.79 each
4 or more for £49.86 each

Stocked

Delivery: 1-2 days   

Qty: 
       

Product Details

The Philips LFH7277 SpeechExec Pro Transcription Kit and Software is the ideal package for handling volumes of digital dictation comfortably and efficiently.
The LFH7277 SpeechExec Pro Transcription Kit package includes the new LFH4500 SpeechExec Pro Software to control dictation and workflow, 2330 foot control, USB Smart key and comfortable 334 headphones.
Visual workflow management allows prioritization of documents to be transcribed to your preference. There is also a Job status indicator which shows the dictation that is pending, in progress or completed. There is also the option to auto transfer dictation files via network, and receive dictation files via email or from an FTP server.
Encrypted data transfer complies with the latest IT security standards, graphical position indicator, automatic built-in file management: file is moved automatically for archiving, speed/tone/volume control, multiple sorting/filter options, real time counter, archive & purge, playback of DSS, WAV, WMA, and MP3 files
PC requirements: Minimum: Pentium II, 233 MHz and 64 MB RAM. Recommended: Pentium III, 500 MHz and 128 MB RAM. USB port (for USB devices)
Software requirements: Microsoft Windows 2000 (SP3 for Digital Pocket Memo support), Microsoft Windows XP